Monthly Archives: February 2006


Bugs, and languages and Xml

Found a big and obvious bug with the batch conversions settings form, where half of the text was missing. Either nobody reported it, or nobody noticed, so I’m not going to rush a new version out today. Seriously, if you ever find anything then please just click on the “report a bug” link over to the right and tell me about it (you don’t need to log in to post).

While I was there, I finished formalizing the localization strings so it will be easy for people to translate into other languages. It’ll just need people to go through and edit a copy of this file, translating the values fields:
 <data name="String in English">
  <value>String in other language</value>
 </data>

Not yet sure exactly how it’s going to work. Maybe through setting up a small wiki-style thing so anyone interested can just edit the page for their language.

In other code, there have been a lot of internal changes so all the default settings are in one place rather then buried in the code. I’m working on a way to store them in an xml file (saving xml done, no problem), and load them when the program starts (loading xml? convoluted and confusing).


Headaches and cleartypes

Very little progress since the last release. Mainly because my main computer’s monitor decided to go ever so slightly but permanently out of focus, and the first thing I knew about it was from the blinding headaches after using the computer for more then a few hours. One lovely big new Samsung TFT later and things seem to be ok (:touchwood:), now I just need something to fill the huge inaccessible gap on a corner desk specifically designed for a deep monitor.

This has all let me find out about Cleartype, and the problems it causes with the program. Having Cleartype turned on gives a different output, and it also slows down the display speed when you adjust the text image. I can’t really say if it’s better on or off, since either way the auto-ramp stuff gives the best output. A quick search shows that it should be possible to turn it off for the textbox and all the image stuff, so I’ll look into an option for that, it’s just annoying that there’s another thing to consider when you post the output as text.